Talk:Known bugs

From YPPedia

Is anyone else finding that the "Save Page" sometimes sends you to "Show Preview" instead? Sometimes I have to hit Save Page five or six times before it actually saves, not as a preview. I have this problem in IE from my computer at work, and also in Firefox from my home system, so I'm fairly certain it's not a browser issue... --Feegle 07:35, 30 August 2005 (PDT)

Check your preferences. Under Editing, make sure that "show preview on first edit" is unchecked. --Barrister 10:51, 30 August 2005 (PDT)
It's not the preferences. It's due to the cookie issue with the round robin server doohickey. A number of other users experience the same thing. Try setting your browser to allow all cookies when you're editing. --Guppymomma 10:58, 30 August 2005 (PDT)

Minor issues -- fixed

  • Shro0m 16:37, 23 September 2005 (PDT): Special:Statistics seems to be fixed. I'm not special, so I didn't want to edit the issue out of the page. :-)
It's not fixed. We've implemented a manual fix because the system variables don't update correctly. --Guppymomma 16:55, 23 September 2005 (PDT)

New header at the top of pages -- suggestion.

  • Shro0m 13:57, 24 September 2005 (PDT): It's great to see the warning at the top of pages. That's a pretty good solution for pages that are meaningless without their graphical components. I have a suggestion: Assuming variable substitution is working correctly and that the warning: "Due to a YPPedia bug, if you cannot see an image or suspect there should be an image, try viewing the page using web1 and web2 instead of www in the URL." is rendered by the wiki or not. It would be trivial to replace 'web1' and 'web2' in the former text with links constructed by substitution (like these two). If the message isn't rendered by the wiki, maybe it can be tweaked so that it is. Just my two cents.
Changed. --Guppymomma 14:26, 24 September 2005 (PDT)
Awesome, thanks. --Shro0m 14:51, 24 September 2005 (PDT)

Cleartext Passwords

I'm kinda creeped out that the same password and login information is used on the wiki, forums, YPP site, client and BILLING site. And further that in all cases (except the billing site, and maybe the client, haven't sniffed that) it's passed in clear text. And even further, that the change password section of the account page doesn't post via https either (from the page source: form method="POST" action="login.wm"). There is nothing preventing a run-of-the-mill packet sniffing attack from causing serious real-life doubloon theft. Here's how:

  1. Set up packet sniffer on any broadcast network (college LAN, encrypted wifi, your own network where you've talked your "friends" into logging in.
  2. Record http traffic for a forum, YPPedia, or YPP login.
  3. Use that login name and password pair to access Billing Status
  4. Buy as many doubloons as ye like. (Or buy as few as necessary to avoid detection. What's the daily limit again, 500? [1])
  5. Log into a YPP client with sniffed account info.
  6. /tip all Doubloons to another pirate, or convert them all to PoE (to launder them? Is PoE traceable from pirate to pirate?) and then gift them to yourself in trade.
  7. Repeat until discovered.

Also, should I ask about this in the forums? --Shro0m 19:40, 1 October 2005 (PDT)

Another question -- The privacy policy says that "In certain areas" that SSL is used (there is a typo there, btw, there's no space between SSL and encryption. It's also worth noting that SSL isn't encryption really, it's a protocol which makes the privacy policy factually incorrect read more here. It would more precise to say "Three Rings uses industry-standard SSL to protect data transmissions via encryption".). Can this document be updated to enumerate the areas where encryption is used? I know SSL is harder on the servers, but having to log in over and over because of the cookie weirdness on the wiki is starting to raise my paranoia. --Shro0m 19:56, 1 October 2005 (PDT)

Further addendum, I've emailed and will update this accordingly if they grant me permission to do so. --Shro0m 20:02, 1 October 2005 (PDT)

It doesn't seem like this would be a problem unless the hacker knew your credit card information. An even safer fix is to use multiple accounts for your in-game, forum, and/or wiki activities. – Yaten talk 20:09, 1 October 2005 (PDT)
Three Rings permits you to save your credit card information with them for future doubloon purchases. Either passwords should be encrypted or non-unified or this feature shouldn't be allowed. I'll paste this into the Technical Issues forum and see if I can get some Ringer feedback. Thank you both for your input. --Shro0m 21:29, 1 October 2005 (PDT)
This probably isn't the place for a discussion of this all, try the Technical Issues forum as the staff actually regularly reads that. --Guppymomma 20:22, 1 October 2005 (PDT)0

This is a really old topic, but I thought I'd add a note that this whole thing is moot since the YPPedia appears to force HTTPS. --Thunderbird 18:09, 10 April 2016 (UTC)

Support page

The Support page ( has a link to the questions forums. That link is broken (the link location is which is 404). The Technical Issues link is similarly broken. --Shro0m 19:44, 1 October 2005 (PDT)

Uhm if you read the Known bugs article, you may notice that this page is for YPPedia bugs only. Again, I'd advise you to take these kinds of discussions to the forum where they're more likely to be seen by the folks that are in charge of these things. --Guppymomma 20:24, 1 October 2005 (PDT)
Yeah thanks, I wasn't thinking when I put that one here. :-D --Shro0m 21:25, 1 October 2005 (PDT)


For me, right now, jumping right to a wiki page without the "www" in the URL doesn't work.
Doesn't Work
--AtteSmythe 10:28, 17 October 2005 (PDT)

bah, now it is again

Latest addition

I'm not so sure the latest addition to the bug list (the comment bug) is something the wiki is doing, as my fiddling in the sandbox was unable to reproduce it. Possibly it was a browser issue? --Thunderbird 12:35, 4 November 2005 (PST)

It's a mediawiki issue as far as I know (Callistan's looked into it as well), so no, it's not my browser. --Guppymomma 21:48, 4 November 2005 (PST)
Looks like it's server specific. I tested it on web2 and web3 (web1 was having issues and reporting 404s). web3 booched up, but web2 was fine. --Thunderbird 21:57, 4 November 2005 (PST)

Minor issues -- tracking $1

Currently the "nowiki" tag is wrapped around the "$1"'s when it should infact wrap the whole line. This will stop "$1" being tracked on the Special:Wantedpages page.

Russgrue 15:37, 3 January 2006 (PST)
Nope, it won't. --Guppymomma 18:34, 3 January 2006 (PST)

Skins & Site header

I don't know if it's deliberate, but when I switched from the 'PuzzlePirates' wiki skin to the MonoBook one, I lost the main site banner (with the Games, World, Forums links). Is that a deliberate thing, if not can it be fixed? --Sagacious 18:09, 12 March 2006 (PST)

Switch back to PuzzlePirates because that's the skin with the banner. :) That and it's actually MonoBook with the banner added as the only difference. --Guppymomma 18:24, 12 March 2006 (PST)
Well I switched to MonoBook for the coloured links - and there is a difference with the colouring... --Sagacious 18:29, 12 March 2006 (PST)
Ah, had forgotten about that test. That's actually us experimenting with different colors for the links to see if it should be changed on the PuzzlePirates skin to help make 'em look more obvious than the more subtle default colors. If you have comments on the link colors, start a discussion section on Fiddler/Orsino's talk page as he's been spearheading that effort (I think we've been sidetracked with all the controversy lately). --Guppymomma 18:50, 12 March 2006 (PST)

Uploading Issues

Whenever I try to upload a file, I get this error (in red): "The file you uploaded seems to be empty. This might be due to a typo in the file name. Please check whether you really want to upload this file." Is this just me, or is it affecting everybody? --Emufarmers 16:42, 7 May 2006 (PDT)

That happens occasionally - something gets done somewhere and it fixes. Someone will poke a techie to fix it... and yes it's happening when I try to upload aswell--Sagacious 17:05, 7 May 2006 (PDT)
Alright, good to know it's not a malignant force bent soley on my destruction. :P --Emufarmers 17:37, 7 May 2006 (PDT)

Something odd on Special:Disambiguations

Look at entry 41 there. Any idea on what to do about that? --Thunderbird 13:35, 19 May 2006 (PDT)

I tried fixing it. All I manged to do was change it to 37. --Barrister 19 May 2006
I managed to change it to 45. I'm so helpful. :) --Guppymomma 14:23, 19 May 2006 (PDT)
There are problems with trying to resolve these 2 entries as the pages supposedly containing the link to a disambiguation page do not exist:
Http:// (Edit) => Stall
(Edit) => Black Horizon
-- Faulkston 12:07, 7 October 2007 (PDT)

Recent Changes

Is this broken for anyone else? It's not loading at all for me. (EDIT)Looks like it's working for me in IE...wonder what's up with Firefox then :P. --Thunderbird 11:05, 30 May 2006 (PDT)

It's working fine for me in Firefox... --Guppymomma 11:12, 30 May 2006 (PDT)
I guess my system just hates me today. Since in addition to this my video capture programs work intermittently lately. --Thunderbird 12:16, 30 May 2006 (PDT)

Page headers?

Is anyone else having trouble with the page headers? Everything's scooted up to the top for me and the YPP menu graphic is on top of the article tabs (luckily I have doubleclick to edit a page turned on). Am I just going insane or is it other folks too? --Guppymomma 07:31, 2 June 2006 (PDT)

Or I guess the image could suddenly just disappear right after I make a comment... Someone should bring me a nice coat with really long sleeves... --Guppymomma 07:34, 2 June 2006 (PDT)
Weird. I wasn't seeing it until I clicked this page to read what you said and it's still there for me now. Way to break it Guppy! --Fannon 07:36, 2 June 2006 (PDT)
The main PP homepage was accidentally updated yesterday - and it wasn't finished. The link bar messed up. Liz has just made changes and she said something like for now she could break the homepage link bar or the forum one - until the other techies come in. Dunno if it has broken wiki one aswell since I never see it thanks to Monobook. Anyway linkie - Explains better than mee!
Fixed, I think, let me know if it's broken for you, IE users. --Lizthegrey 07:38, 2 June 2006 (PDT)
After a force refresh it appears to be fixed on IE for me! Liz rocks. --Fannon 07:42, 2 June 2006 (PDT)
Me (IE user) no tengo una Forum Linkie Bar. Cache cleared etc. --Sagacious (talk) 07:43, 2 June 2006 (PDT)
I was trying to take back what I just said but was sniped! It is now all white and I have to hover the mouse to see the Games, World, Forums, etc links where the bar used to be. --Fannon 07:45, 2 June 2006 (PDT)
My page just starts from Welcome Sagacious (We remember you) Logout - impossible to scroll above that line. --Sagacious (talk) 07:46, 2 June 2006 (PDT)

Problem with the puzzle

I have gotten a new problem with the puzzling. While I am playing a puzzle, it will glitch and repeat over and over and over and over, until I go literally crazy from the repetitivness. It's like the problem comes from a broken record and then the system either lags me so bad, my computer is running consistently until I completely close down YPP or I get completely disconnected. My money is good and I have played this game for an extremely long time, but this problem has just recently started and I'm getting to a point that maybe my money isn't good enough and go elsewhere. I have asked for help several times and this will be my last attempt. Please help.

Please see my response here. -- Cedarwings (t/c) 21:54, 1 December 2007 (PST)

Moving pirate pages

I observerd two cases now, that when a pirate page gets moved and I uploaded a new portrait picture (to match the new page name) it didn't show until I edited the pirate page again. This is no browser cache issue, since the old picture still showed being linked by the page with the name before the move. That link was dropped too, after editing the moved page. --Alfwyn 13:22, 12 February 2008 (PST)

Next time try purging the page to see if that does it. --Guppymomma 14:12, 12 February 2008 (PST)
I will - thanks --Alfwyn 15:13, 12 February 2008 (PST)
Purging the pirate article made the image appear on the pirate page, but the image didn't show a link to the pirate page. Purging the image page didn't help, but editing the pirate page did. --Alfwyn 09:27, 4 March 2008 (PST)

A probably somewhat related quirk occurs when changing pages into a redirect. The redirect will show fine after 'save page' but revisiting it shows still the old content before editing. Editing or purging the target of the redirect does fix it. --Alfwyn 12:14, 20 February 2008 (PST)

Image Links

When an image is linked to via [[:Image:name]] rather than displayed, it seems it doesn't count as a link for the image. See the image linked to by GCPP:Proposal-Whitling at the bottom. Perhaps this is a feature, not a bug - but it means that an image showing no links might still be referenced somewhere. --Alfwyn 15:27, 24 February 2008 (PST)

Just out of curiosity, when this happens, try hopping over to Special:Statistics and see if the job queue is at 0 or not. --Guppymomma 09:16, 28 March 2008 (PDT)
Stayed at 0 as far as I saw. This phenomenon is pretty stable and reproducable and doesn't seem to suddenly change. --Alfwyn 10:04, 28 March 2008 (PDT)

Disappearing/Not Registering Edit

I had yesterday an edit disappear for me (seems it never registered and never appeared in recent changes or the edit history, but no error message either). I'm pretty sure I used the 'save' button and not the 'preview' one, but there isn't a proof for that. I would have normally dismissed that as some random error, but the question about the disappearing edit on the forums made me wonder. So if anybodey else experiences something like this ... --Alfwyn 14:33, 28 March 2008 (PDT)

After some more thinking and experimenting I guess it was a case where I didn't notice an edit conflict and just pressed save again (sometimes my browser marks the button, instead of pressing it, so I'm used to press it a second time). This will discard the not integrated changes and leave no trace in the edit history, since the diff is empty. I fits the symptoms and edit history in my case, so I guess that must have been it, sorry for the confusion. --Alfwyn 08:30, 29 March 2008 (PDT)

Sectional Redirects

Currently, there is a bug with the PuzzlePirates skin which prevents sectional redirects from working correctly. They work fine under MonoBook, but the #section element doesn't get passed onto the URL properly when using the PuzzlePirates skin. Tested using User:Sagacious/Redirect under various browsers, including Safari for Windows, Firefox 3 and IE7. I believe Fiddler has now forwarded this on to the web maestro. Not sure if it's major or minor. --Sagacious (talk) 21:28, 11 July 2008 (UTC)

Minor. Yes, it was passed on to the web design person. --Guppymomma 22:16, 11 July 2008 (UTC)
The question is, how do we handle it in the meantime? The pages Autocratic, Oligarchic and Democratic got changed to normal pages by one user because sectional redirects don't work. Since they DO work, but not for the majority of users, do we change them back, or leave them? On a side note, I'm not sure if the loading issues with the PP skin are quite so minor. I've found myself unable to connect to the YPPedia at all sometimes because my browser seems to be choking on something in the skin. --Belthazar451 22:24, 11 July 2008 (UTC)
There are very few sectional redirects. Just leave the pages as is with the sectional part. Loading issues are not about sectional redirects and should be addressed elsewhere. --Guppymomma 22:33, 11 July 2008 (UTC)

"Current events" in navigation bar links to a non-existent page

Haywoodx pointed out to me that it is linking to YPPedia:Current events rather than Current events. I'm using the MonoBook skin, don't know that it would make any difference. -- Faulkston 05:55, 16 July 2008 (UTC)

I don't think it's a skin issue as I'm using the Puzzlepirates skin. I'm not if this broken link is an upgrade issue or not but I have fixed the link. -- Cedarwings (talk) 11:09, 16 July 2008 (UTC)

Minor Searching Issue

When I search for 'Beyond', I get no results, but it should find at least Beyond the veil. Is the word really that common that it was dropped from the index ? --Alfwyn 19:51, 16 August 2009 (UTC)

Stealth empty line

An empty line at the start of an article doesn't show and will be (accidently) deleted by subsequent edits (or just a preview before saving) if not manually inserted again. I just had a bit of fun figuring that out, when translating templates like {{Ocean table/Midnight-yes}} (Usage) for the german wiki. There the empty line at the start is important. Unfortunately wikipedia behaves the same, so upgrading won't fix this. It happens to me with IE6 and firefox, so it may be browser independent. --Alfwyn 19:56, 22 September 2009 (UTC)

Nested templates/inclusion can cause severe overestimates of size

I've stumbled over two cases now, where the showhide box template wouldn't expand anymore ([2] [3]). Like detailed at Talk:Gorbatchef I guess this is due to a Mediawiki bug that severly overestimates the page size in some cases. I think we should add it to the page, probably as minor bug. --Alfwyn 16:03, 29 December 2010 (UTC)

I added it to the page after a few more cases surfaced ([4] [5] [6]). We can track those by checking Special:Whatlinkshere/Showhide. --Alfwyn 16:40, 10 February 2011 (UTC)

unable to upload zipped files


I *used* to be able to upload ZIP files. the upload function still *says* that ZIP files are OK. however, when I try to upload, I get that error.

-- Franklincain (t/c) 21:56, 15 July 2012 (PDT)

I am now unable to upload PDF files. I used to be able to do so. I have only tried updating an existing one File:Cerulean_ocean_map.pdf. Discussion also on YPP forums. Please advise! Chupchup 23:16, 9 January 2013 (PST)
Once you get in there to allow more files to be uploaded, perhaps you can permit .odt, .doc, .docx, .xls, .xlsx, and the like, because sometimes people write useful spreadsheets as third-party software. Or do you suggest those should be hosted elsewhere? Chupchup 23:17, 9 January 2013 (PST)
[] is a nice free hoster, along with 4shared... Or google docs if you are really fancy =] Easier viewing instead of having to download. Avastme Talk 23:22, 9 January 2013 (PST)
Due to security concerns, we will no longer be able to upload .pdf, .zip or .mp3 files --Clotho 12:22, 13 January 2013 (PST)


The file history boochage is fixed, which fixed the pet template issue. Thumbnails are working again except for (new) animated gifs. And the show/hide issue isn't listed. --Budclare2 19:35, 20 June 2016 (UTC)