• Play
  • About
  • News
  • Forums
  • Yppedia
  • Help
Personal tools

Talk:Puzzle Pirates installation guide (Linux Ubuntu)

From YPPedia

Do we have a page that references technical issues, and solutions? Should there be more technical issues articles on the wiki?

We don't yet. I did link to this from Puzzle Pirates. If you have other technical issues that merit an article, pick a good name and create them. We can create a technical issues category to index them. --Guppymomma 19:18, 9 March 2006 (PST)
I'd love this, as I don't have nearly enough time to write up documentation for common technical issues, and if I can send people to the wiki, so much the better! --Lizthegrey 00:28, 10 March 2006 (PST)
Okay, template created. I'll fix it up more later. For any other technical issues pages you create just pop {{technical issue}} on the first line. Edit: And you can see what's in the category at Category:Technical issues. --Guppymomma 09:53, 11 March 2006 (PST)

Contents

List of tech issues needing wikification

Just starting a to do list of sorts. --Guppymomma 14:45, 29 April 2006 (PDT)

Disputed

Hi, sorry if I used the wrong tag for this! But, this page has several problems. Firstly it's extremely out-of-date; for instance, the recommendation to download Java SDK 1.4 - both a security risk, and no longer compatible with the next client release. Most Linux distros can use Java SE 6 (the SDK/JDK is not needed and is a huge download; only the JRE is needed to run programs.) Also, nearly all Linux distros have a package management system, which obviates the need to download direct from Sun. I use Ubuntu; the only command needed there is sudo apt-get install sun-java6-jre. But the method changes since other distributions use completely different package management. The beginning user should never be encouraged to download/install software directly when it is available through package management. At any rate, I don't have time tonight to update the article, but I will have time during this week to get it improved. I didn't realize there was an article here, I came because of a link from the forum, so since it has gained a bit of currency I thought it best to tag it as bad, rather than erasing a section or two and rambling on without collecting my thoughts. --Chupchup 08:17, 15 July 2008 (UTC)

I gave this a bit of thought and couldn't really come up with any alternative tags to stick on the page, so leaving disputed up there is fine for now. I'm pretty sure there's a template for marking stuff as out-of-date somewhere. Thanks for letting us know that the information was erroneous! --Featherfin 14:14, 16 July 2008 (UTC)
{{Update}} (Usage) is what you are looking for :-) --Sagacious (talk) 17:38, 16 July 2008 (UTC)
Actually, no, the update template does not seem to be a strong enough wording to discourage people from using the instructions as-is. There are security problems with installing Java 1.4. The package management system could become confused by a manual Java installation. The update tag is low-key, and appears to address editors only, rather than the reader. I'm adding back the disputed tag on top of the update tag. Chupchup 05:53, 17 July 2008 (UTC)

OpenAL on Ubuntu

I'm not sure where this information is most appropriately presented. Ubuntu 8.10 (Intrepid Ibex) comes with the libopenal1 Debian package installed out of the box, but not libopenal-dev. The latter is needed for sound to work under the org.lwjgl package used by YPP. I found that out after much frustrating research on other sites and discussions, because nothing is mentioned in YPPedia or the YPP forums. --Fuzzybeard 05:17, 1 March 2009 (UTC)


I thought I'd append this. On Ubuntu 9.10 neither libopenal1 nor libopenal-dev are installed by default. So you'll need to run "sudo apt-get install libopenal1 libopenal-dev" to get sound working in YPP. --Harvie4 04:50, 15 November 2009 (UTC)

AWT toolkit on Ubuntu

I'm running Ubuntu 9.10 Karmic. After downloading and installing the file, the game wouldn't start. I was getting an error that said, in the launcher log:

(section of code starts. I don't know the proper wiki formatting for this, if you do, please apply it) Exception in thread "Getdown" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit

  at java.awt.Toolkit.getDefaultToolkit(libgcj.so.10)
  at java.awt.EventQueue.invokeLater(libgcj.so.10)
  at com.threerings.getdown.launcher.Getdown.a(Unknown Source)
  at com.threerings.getdown.launcher.Getdown.a(Unknown Source)
  at com.threerings.getdown.launcher.Getdown.a(Unknown Source)
  at com.threerings.getdown.launcher.Getdown.e(Unknown Source)
  at com.threerings.getdown.launcher.Getdown.run(Unknown Source)

Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: libgtkpeer.so: cannot open shared object file: No such file or directory (section of code ends)

I solved the problem by installing, from the Synaptic Package Manager, the AWT toolkit packages. There were two of them and I installed both, though perhaps only one is necessary. They were named: libgcj10-awt and libgcj9-0-awt --Gyrfalks 00:31, 4 January 2010 (UTC)

Probably only libgcj10-awt was necessary, since it wanted version 10 (libgcj.so.10) of the library. --Alfwyn 12:42, 4 January 2010 (UTC)

Big updates for Ubuntu 10.04 (Lucid)

I tested these instructions on a fresh install of Ubuntu 10.04.1 (aka lucid) i386 desktop. I found that they didn't work very well. So I have updated them to provide working instructions for finding and using the Sun Java JRE, running the installer shell script, and fixing up the dekstop iccon.

Specific issues that might need some more explanation:

The Sun Java packages (sun-java6-jre and its dependencies) are in different repositories in different Ubuntu versions. They used to be in multiverse and are now in the Canonical partner repo (which I think didn't even exist for some earlier versions). Hence the slight vagueness.

Before writing the instructions to use Sun Java I tested the openjdk jre. The version in 10.04.1 has at least the following bugs: rendering is rather slow (too slow for my rather antiquated test box), and the Carpentry puzzle left bits of the edges of carp pieces behind as they were moved, corrupting the display. Under these circumstances I thought it best to provide instructions on how to use the Three-Rings-supported Sun JRE rather than OpenJDK, even though the latter is much more fully Free Software and even though Sun JRE is less well supported in Ubuntu in general.

I recommend setting the game's JVM location to /usr/lib/jvm/java-6-sun, because that way the JVM which is used for YPP is independent of the system default JVM. So if the user installs the OpenJDK JVM as well there is no difficulty over which version YPP should use even if the user has (or later makes) the OpenJDK JVM the system default JVM. Of course on other versions of Linux things may be different.

It would be nice to see these instructions enhanced for Debian. I think the main difference is simply that the Sun JVM is in Debian's non-free repository, so it's quite likely that at least the more sophisticated of Debian's users will be able to figure things out from the instructions I've provided.

It is a shame that the installer shell script forgets to make the desktop icon executable! We could get rid of the last bit of the instructions if this installer bug was fixed by Three Rings. (Making the icon executable is necessary because of a security feature: modern versions of Linux do not allow non-executable .desktop files, shell scripts, binaries, etc., to be executed simply by clicking on them. That makes it harder to trick naive users into downloading programs and running them.)

-- Ian Jackson (Aristarchus of Special Circumstances) 22 August 2010

Debian

Just tried openjdk6 with debian (sun java no longer supported/a pain to install) and so far it seems to run fine (some graphic glitches during installation). I used the play from webpage method, just surprised openjdk seems to be compatible enough for YPP now (wasn't when I tried it a few years ago). Basically the following packages needed installing: flashplugin-nonfree, default-jre, idectea-6-plugin (using firefox/iceweasel that is).

Guess I'll write something more comprehensive if it turns out to be stable enough for more than playing hearts.

--Alfwyn 07:00, 2 February 2015 (PST)

Hm, can't charge balls in rumble using the keyboard (mouse works, but I'm not used to that). Openjdk7 didn't do the trick either. --Alfwyn 08:42, 2 February 2015 (PST)
That issue doesn't really seem to be an openjdk one, but a kde key repeating one (see for example this discussion). Issuing a "xset r off" to disable key repeats fixes rumble for me. --Alfwyn 11:42, 2 February 2015 (PST)
Puzzle Pirates is supposed to disable key repeat when starting such a puzzle. It does for me under KDE and Gnome on Ubuntu 14.10. Sometimes if I'm multi-clienting it will get confused, and leave repeat off when I exit the puzzle. Chupchup 16:04, 2 February 2015 (PST)
Oh yeah, and icedtea has been working fine for me when I accidentally use it in the aforementioned OS. It's usually only by accident, and for best results I used icedtea 7.x, but yeah, it's come a long way in recent years. Chupchup 16:46, 2 February 2015 (PST)
Powered by MediaWiki
Attribution

Puzzle Pirates™ © 2001-2016 Grey Havens, LLC All Rights Reserved.   Terms · Privacy · Affiliates